Gra nie włącza się (segmentation fault)

#1

Parę razy udało mi się już uruchomić grę (co prawda bez muzyki), jednak pewnego razu, gra nagle wyłączyła się w trakcie walki. Nie wiem czy to istotne, ale od tego czasu Heroes nie chce się załadować. Załączam log.

Starting... 
Creating console 0
	 Initialization: 1
	 Data loading: 65
	Mod handler: 0
	 Mod filesystems: 33
Basic initialization: 100
Initialized logging system based on settings successfully.
Error: campaign movies was not found!
Error: campaign music was not found!
Loading settings: 103
VCMI 0.94 (client)
Error: SDL says that 1366x768 resolution is not available!
	Initializing screen: 31
	Initializing video: 2
	Initializing minors: 0
	Initializing sound: 9
Initializing screen and sound handling: 10
[smk @ 0x23b8e40] max_analyze_duration 5000000 reached at 5066160 microseconds
		Bonus type handler: 5
		General text handler: 4
		Hero handler: 2
		Artifact handler: 0
		Creature handler: 0
		Town handler: 0
		Object handler: 2
		Def information handler: 24
Naruszenie ochrony pamięci (core dumped)
#2

Dodam jeszcze, że ustawiona jest rozdzielczość 1366x768, która niestety nie działa. Może to jest problemem?

#3

Zdaje się, że czasami tak się zdarza, jeżeli VCMI zapamięta ustawienie rozdzielczości na taką, która nie jest obsługiwana.

Spróbuj usunąć plik z ustawieniami użytkownika — to powinno przywrócić wszystko do stanu domyślnego.
W katalogu domowym jest ukryty podfolder .vcmi — usuń stamtąd plik config/settings.json.

#4

Dziękuję ;D. Z dźwiękiem też udało mi się sprawę rozwiązać – w mojej instalacji gry katalog mp3 oraz niektóre pliki w nim są nazwane w inny sposób niż powinny być (wielkości liter).