Game crashes when it is about to load a map


I have an Asus MemoPad7 with android 4.4.2, yesterday I installed VCMI on my tablet, I downloaded the GoG version of HoMM3Complete, copied the files to the given directory, I launched the VCMI again, the 3DO logo appeared, the game loaded, I was able to move in the menu, click anywhere, but when I wanted to start a single player skirmish or campaign when I clicked on the start button the loading screen appeared, after 1 sec VCMI threw me out saying: VCMI stopped working. I tried it again many times, but still always the same error. Any ideas or anyone had the same problem?

There is bug report of player who have crash, but on different device: #1957

AFAIK Asus MemoPad7 has Intel CPU, it is not supported yet.

On Android x86 there is proprietary libhoudini provided by Intel that let it run ARM binaries just fine. As far as I aware it’s pretty fast and works reliable for most of apps.

Thank you guys for the answers. So that means, that I have to wait, untill intel will be supported.

It’s really good idea to do what author of this port recommend on Google Play page - contact him using email: [email protected]

Might be you can help him to improve support of your device.