I changed the resolution to 1440x900 and started fullscreen function.
the game crashed and i get this error…

VCMI 0.94 (client)
Error: SDL says that 1440x900 resolution is not available!

what do i do…

I use ubuntu 12.04

AFAIK this may happen if you select resolution not supported by video card/display. We still don’t have proper check for this kind of errors.

You can edit file ~/.vcmi/config/settings.json to change resolution manually. Or just delete it to reset settings to default.

i have tried to reinstall it but the problem still appears. i do not have this file config/settings.json

This file located in hidden directory “.vcmi”.

Open your home directory, press Ctrl+H to display hidden files and find .vcmi directory. This is where you can find file config/settings.json

Or just open terminal and type this command:

rm ~/.vcmi/config/settings.json