Compile from source on Linux - Boost issues

I’ve been trying to compile the game from source on Ubuntu 14.04. First I ran into issues with BOOST_HELP being unknown, which was introduced in boost 1.59 (and the lastest boost verstion available via Ubuntu repo is 1.58). So I manually installed boost 1.64, but now I run into different issues when trying to compile, starting with:

Linking CXX executable ../build/vcmiserver
CMakeFiles/vcmiserver.dir/CGameHandler.cpp.o: In function `sleep':
/usr/local/include/boost/thread/pthread/thread_data.hpp:278: undefined reference to `boost::this_thread::hidden::sleep_until(timespec const&)'

along with a bunch of similar boost-related errors.

Is there a particular boost version that vcmi requires? Or does this look like I stuffed up the manual boost install? Any help would be appreciated.

I suppose Boost should cause less issues now since automated tests using GoogleTest and all other Boost libraries we using can be much older and would still work fine. If you still have problems with Boost please join our slack and ping me about that:

And yeah our Travis CI builds using Boost 1.54 and it’s seems to work just fine. Though it’s past we had -DENABLE_TEST=0 for Travis.