Can't load saved game

Hi, I am new to VCMI, so treat me as noob here.

I found VCMI because of Android port made by Pelya. I know, that Android port is not supported, so I will not report anything related to VMCI on Android.

When I found, that I am not able to load saved game on Android, I wanted to know whether it’s Android related bug or not, so I tried running VMCI also on my desktop PC with Windows 7.

The same issue as on android seems to be present also on Windows. Whenever I try to load saved game (autosave or my save), the game freezes.

These are the lines related to this issue:

Loading procedure started!

Reading save signature: 0
Reading handlers: 39
bad allocation

These are also the last lines before game freezes…

If there is anything I need to do to be able to save/load games in VMCI, please advice, I will be grateful for any help or info.

Hi and welcome to the forum.

Maybe one of the programmers can better help based on what I believe is the text in the console that you wrote above. But just to make sure we are on the same pace, what you are experiencing is the following:

  • you can open any map, play (build, fight…), save etc
  • but if you close and reopen the application, you cannot load the game you saved? If yes, does that apply to any map you try to play?

Yep, I can start game on any map, I can build, fight, everything.

But today I tried it again just to be sure and found another error. Once I got error after first population (end of the week).

After population I got this error when pressing button for ending a turn:
System message: You were identified as player 2 while expecting 0
System message: You are not allowed to perform this action!

These errors are weird. Could it be caused by some error with game files?
My system is not in English (Czech), so maybe even though I followed instructions for changing system locale for WOG installation, something still went wrong. Is there any way to find, whether game files are OK?

I don’t think so. It’s an already known bug #729 ]. I hope it’s fixed in SVN (not sure, as the bug is practically not reproducible with debug builds I use).

Save/load should work without any additional steps.
Please upload your savegame files, and I’ll look into them. (the all three files from Games/ subfolder).
Do you have English version of H3 installed?

Sorry, I missed your reply.

I have both, Czech and English versions of the game. And I have same issue loading savegames with both.

Here is link to one of my savegames:

there almost no compatibility between versions… if you load older version save it probably won’t work. also keep in mind that saving format is very diffrent than one in original heroes3.

if you saved a game, and try to load with the same version of game, and it fails, it’s sure a bug.

Also, we have a bugtracker for such discussions.

I am saving and loading with one version of VCMI.
Savegames of original game are only one file per save, not three as with VCMI, so you cant mix it.

I noticed that, but I cant login there.
And I was not sure whether its bug in VCMI or just between chair and keyboard :wink:

Not being able to login there could also be between chair and keyboar[size=92]d (I bet WM likes this one;)[/size] What is the error that you get?

As for your issue here, I was able to load the game you attached without a problem. So I suspect you may be missing some game files. Could be files from the original H3, or WoG, or VCMI… or even some files mixed up on your PC with Pelya’s files for the android port. (?) It may be hard to get to the bottom of this, unless you try a clean install of H3 (SoD or Complete) + WoG 3.58f + latest VCMI. And I do recommend first doing it with system settings on English, and only then switching to Czech, to see if that has something to do with it.

[size=92]Hodně štěstí![/size]

I am trying to login with same credentials as for forum and I am getting this:
“Your account may be disabled or blocked or the username/password you entered is incorrect.”

Yeah, thats what I suspect also, but what I did was what you suggested. I installed H3 Complete Czech on Win7 64. Then I switched OS environment language to English and installed WOG 3.58f and then copied VCMI to game folder.

Because I was getting this issue, I downloaded H3 Complete in English. Installed WOG to H3 En folder (again with language set to EN) and copied VCMI to H3 EN.

Only after this I wrote first message of this thread…

I still suspect, that changing environment to English on Czech Windows is not enough, but I dont know how to verify that all game files are OK after WOG install.
I tried to play WOG and original game from same folder as VCMI and both works well, so I am a bit clue less here :frowning:

I believe you need to use “Signup for a new account” first time on Mantis. Accounts created here on the forum are not automatically ported over there.

As for the issue, I’m a bit clueless as well, now that I see you have it after a clean install as well. I assume when you copied VCMI over the game files in the end, you used the 0.86 files from the forum release (i.e.: no Pelya’s), and you did overwrite if asked…? I would have also thought of compatibility mode, but I also have Win7 64 and I don’t remember having the issue. If I can think of sth else, I’ll post here.

Hi Zamolxis,

I would like to report that, after update to 0.87 I can save/load just fine.
I am still unable to load old saves from 0.86, but I am not sure whether this is issue or normal behaviour.

When I try to load save from 0.86 I am getting these lines followed by errors:

Loading procedure started!

Reading save signature: 1
Warning: very big length: 284098816

Interesting is maybe that line with signature, if you compare it with 0.86, it reported zero signature.

Anyway this post is only for someone still interested why this happened in 0.86.

I am now happy, that it works in 0.87!

During development phase old saves become obsolete with every new release, so it’s perfectly normal that you can’t load older saves in 0.87. I can’t say why it failed for you in 0.86… many bugs were fixed, you can check the log on Mantis if you’re really curious to identify to which this may have been related.

@Tow&co: something you prolly thought of already, but just double checking — will at least the 1.0 release have such architecture that as of then all saves will be compatible with future releases as well?

Not very likely. Save format changes becauses the data stored by engine changes. If the old data is incomplete or buggy, there is not much we can do. It’s possible to keep format compatibility (by correcting obious errors and filling aps with default values) but it would require additional code, more with every next release. Apart from work it’ll also likely cause problems (including results of bugs in old builds gets loaded and re-reported for the newer build).
However 1.0 is still pretty far ahead and by the time of its release, things may change. We’ll how stable things will be then.

I think about different solution (well… more like a workaround): having several VCMI builds work on a single H3 install. They could be put in subfolders or so. Then you would be able finish your game using a previous build and use a new one for builds.