Cannot generate random maps at all


I firstly installed vcmi 0.99 and then all the mods i could find here.

but it seems that if i start a basic random map as any wogger does could not create map under these circumstances

wog options do not exist.

great amount of hero portraits errors in the console.

i don’t even know what to and how to even start this game. i couldn’t find any information on any mods. meaning it does work, it doesn’t and so on. it’s just there and that’s it.

can someone explain to me how to make them work?

  1. Install original H3 game, preferably from GoG
  2. Install vcmi to same directory
  3. Use VCM_Launcher to install trusted mods from our server. Pay attention to VCMI essential files -> Default templates mod, which is a part of Windows package.

And yes, WoG options do not exist.

When you launch vcmi_launcher.exe you must click Mods section and you’ll see something like that.

Yellow arrows mean that mod can be download via launcher and ‘self-install’.
Red circle means that mod is installed and is DISABLED.
Green mark means that mod is installed and is ENABLED and affect the game.

To get more information about mod you must highligh it and click bracket (>) on the right side of the panel.

If you want to download untrusted external mods [sic!], you must read this:

Also you want to make sure each of your mods folders, when open has a content folder and a mod.json file…if you open the mode folder and see another folder with the town name for example, you will need to dig down til you find the above two, copy and paste them in the right place.

The exception I ran into was Bastion zip…when unzipped into mod folder it places another mod folder and a mod.json in your Mod Folder…delete the .mod then dig into the mod folder til you find the Bastion folder with the content / mod.json folders. Copy that Bastion folder and paste it in your vcmi mod folder, you should then be good to go.

Draeganfire - you are completely wrong :slight_smile:

I strongly advise you not to do this that way! Mods within mods are for purpose - these are submods ana allow player to customise some mods. For example - you can play WoG without Commanders, or without stack experience, when you disable particular submod in launcher menu. Or you can play Cove without HotA’s Conlux rebalance. Or you can play Axolotl’s Creature Pack only with creatures which you like best. So your way can screw customisation :slight_smile:

Look at installed mods in launcher menu. Some mods have grey bracket (>) to the left of mod’s name. Click on it - you’ll see list of submods. That’s the way thad mods within mods directory work.

I strongly advise you not to unzipp file if you only player, not modder. When mod is in form, alpha version of map editor load graphics without errors. When you unpack .zip and launch map editor you get bunch of errors and warnings.
Second thing: it’s easier to update mod from version 1.0 to 1.1 (or any other) when you have single file. Only you have replace one file - If you have unpacked content folder, you have replace dozens of files, which is not easy for less experienced users. And when new version of some mods have diffirent files structures - updating leads to crashes.

So, all mods from laucher and wiki mods site are proper and have been tested. You must only copy mod to your MOds folder and enable it in launcher.

Any updates on the random map generation issue? Doesn’t want to work for me either, same error.

There are no issues to update, only improper installation. If you have Random Map Templates from VCMI Essential Files ‘mod’, it will work.

But it’s strange that even with random maps templates it is impossible to create random maps with 5 players. And templates allow to create such conditions…

Fair enough, may well be an installation issue. When I try to update the vcmi mod, I get the attached error message. Also ~/.local/share/vcmi/Mods is currently empty (working under Ubuntu now).

Yes, because updating VCMI essentian files via launcher is the worst thing you can do. Don’t ever do that. Download latest vcmi version 0.99+ from official sources and just play.

Bt. Your launcher should look like attached screen.

Well, that’s something to report as a bug.

Thanks, definitely doesn’t look like this for me. I’ve been trying to follow the installation instructions at If that info is out-dated, what’s the “official” installation procedure?

Sorry, it’s a mess.

Our daily builds do not contain extra RNG templates and there simply no way to download them. All you can do is grab old stable Windows build and manually copy extraResolutions, defaultTemplates and bonusIcons into your ~/.local/share/vcmi/Mods/vcmi/Mods directory.

Thanks, that did the trick. Copied over the entire vcmi mod folder as there wasn’t any before at all. Both high-resolution and random map generation works now. :slight_smile: