Android port

I do believe shipping Manual in the package would help a lot. People seem to rarely find it, and at least it clarifies what VCMI is all about without getting into details.

Still, people don’t like to read anything and just play it NOW, so giving additional info impossible to miss may help them.

Maybe we should show show a kind of splash screen (when running vcmi_client) with info about the project and its progress when the game is run for the first time on the machine?

I’ve got a minor progress - now it loads main menu on my Evo, but crashes when I’m pressing any button.
Adding extensive debug to the code has shown that sometimes VCMI tries to read memory past the end of buffer created by CLodHandler::giveFile(), inside CDefHandler::getSprite(), maybe this is Android-specific though, because running it under Valgrind on PC has shown no errors (but I did very few tests). Adding a safety margin to the buffer returned by CLodHandler::giveFile() seemed to resolve the problem for now.
The next crash is inside CDefFile::loadFrame(), I’m going to fix it next week.
The patch became extremely ugly, don’t look there please 'till I’ll clean all the things up.

Edit: I’ve managed to run it to the point of fighting battles (at least on my HTC Evo), it still crashes often at random. So I’ve published it back to market, with big fat warning at the top.
installer file, extremely ugly patch

Wow Pelya, congrats, i just tried the new version on Samsung GT P1000 and made it as far as the in-game. The game is so far playable, though i didn’t get to do much yet other than load a map and enter combat.
I’ll be doing some extensive testing of it and will upload pastebin logs for the major issues i encounter, they might help development.

So far I have these if they might help:

pastebin.com/xGrsaHRb - game crashes to desktop when saving

pastebin.com/0nHGkV8q - game freezes when selecting the Quit to Desktop menu option

Android 2.3.3 | Overcome 2.0.1 Hermes ROM | Overcome 3.0.1 kernel

Definitely working much better, it runs, can start a game and battles seem to work properly. However there does seem to be a crash when upgrading creatures (only tested on 1st Tier creatures).

Other than that I have not had any other crashes yet, though I only played for about 5 minutes

Edit: Crashed during battle. Progress is still great though

That’s a very good idea. It would clear some confusion and reduce the risk the project gets (unfairly) a bad name because of those thinking it’s “just another mod”.

I can now also start a game. Build buildings, entering battles work. I’m also happy that it’s smoother than the heroes2 :slight_smile: I have the Desire Z with Cyanogenmod7 (Android 2.3.4), if you need logs, just tell me!

Also, maybe you should consider pulling it from the market and setup a beta testing site or something like that. Just to avoid angry e-mails from people expecting it to work 100% :slight_smile:

Just tried today on the EVO 3D, and it doesn’t make it past the SDL splash screen. It briefly flickers to black with a tiny squard with “Ab” inside it in the top left corner, but after that hits home screen.

Can someone please help me with a guide how to install wog I cannot install it. I only get error :frowning:

denker - rad the error and think about what is written
if you have set wrong language on system the instalation won’t start (it need US or RU)
if you got information that exe can’t be opened on your system it means taht you must install heroes3 then WoG on PC then copy files to instal Android port of VCMI (both PC_WINDOWS and PC_LINUX need both oryginal heroes 3 files and WoG files)

also keep in mind that VCMI is rewrite of H3 engine, not just an another mod (but makes able to be run on wider platforms and aims to be easy moddable in future - heavens better than hackish things that WoG makers had to do)

Same issue on my HTC Sensation

I have set to the right laguage. When I install I get some wog files may be broken :frowning:
I have tried to reinstall it now but it’s still the same error.

That’s strange. Maybe the installer files are indeed broken? You may try redownloading WoG installer from our server download.vcmi.eu/WoG/WoG_Install.7z ].
You can also try the new WoG+ERA installer heroescommunity.com/viewthread.php3?TID=34324 ], however I don’t know if this WoG setup works with VCMI.

Can you or someone please send me the files? I can prove to you that I have bought the game if you want :slight_smile:

Funny thing - in 0.85.02 version game crashes when u try to open creature’s info, but battle goes right, but in 0.85.03 game often crashes during or after the battle :wink:
Anyways, keep up a good work! btw how can i make a donation?
P.S. sry for my bad english

If I remember correctly, VCMI team doesn’t take donations :wink:

But maybe pelya does? There is my log file i hope it will be helpful.
logs

Works on Motorola Defy. First I’ve try to install heroes with WoG included, but they have no work (only Ab button), but when i found a PC with USA system and installed WoG normally on HOMM III, VCMI starts!

working files: [Link removed]

Please refrain from posting that stuff here.
Can an admin remove that link ?

Hosting provided by DigitalOcean