0.72 bugs and issues

Have you added smpeg.dll to your heroes3 folder? Music started working as soon as I added it.

Thanks. Now it works, but:

**#45 **Music does not change when switching between towns.

#46 - When gaining the skill from a Scholar (and probably same from Witch Hut), “Intelligence” word does not fit on one row:


It’s possible that’s the longest word in a skill name, but just in case, maybe there should be a check for message windows to prevent that words are split in a funny way (ideally being that they are never split).

EDIT: - Redundant quotation marks from skill description are still there:
[size=75](reported by dikamilo[/size] as issue #45 in the 0.71b bug thread - Logged now in SourceForge)


#47 - bug with hero advancing
if hero gets twice the same ability at basic level (which shouldn’t happen but happens)
the hero window would make crash (in debug version it says it exceeded vector boundary, probably you just know what happened)

EDIT: it happens when hero gets a few levels at once
EDIT2: it hapens with advanced and expert too

INFO: it was tested with last build so may not apear in base vcmi 0.72

[size=75]Bug also in base vcmi 0.72 (I got Advanced Leadership like 5 times while advancing after a battle + crash) so I gave it a log number. Possibly related to #27 tho.


For instance this bug happens when the hero is leveled up several times after a battle. The server send several messages saying that the hero level up and to choose/upgrade a new ability without checking the previous choice. However each choice depend on the previous one.

#48 - Target creature loses stack size box from the moment the enemy shoots at it, or even starts to walk/fly towards it:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Targetcreaturesloosesstacknu.jpg [size=75](Arch Devils losing stack number box while Archangels were flying towards them)[/size]

In H3 only the stack number boxes of the attacking/moving creatures temporary disappear during the attack/move. Target creatures stack number box should remain displayed until the moment of the impact, when it disappears just for a fraction of the second in order to be updated accordingly (depending on casualties suffered).

#49 - Large stack numbers don’t fit very well in the boxes:
VCMI: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-StacknumbersVCMI.jpg vs H3: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-StacknumbersH3.jpg

#50 - Background creatures disappear from the Battle Casualties window if we move the mouse cursor out of the client interface:
Cursor still inside client interface: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Backgroundcreaturesbeforemou.jpg // Cursor moved outside client area: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Backgroundcreaturesdisappear.jpg

We can either scale number box or reduce info amount to “9K” as in H5. In second case, while using higher resolution the exact size of stack could be displayed below main window.

Of course, proper fonts will help as well :wink:

That’s indeed an alternative, though H3 had quite an elegant looking box, even if the number was 1 or 10000 (I’d start using the “k” maybe as of 100.000 or even as of 1.000.000 only):

#51 - Crash in the beginning of the “Chasing a Dream” map, when picking the Badge of Courage artifact next to the town:


I could not reproduce it:

  • Same map but other random artifact next to the town, worked fine
  • Custom map with Badge of Courage from editor, worked fine as well

So I hope the attached Server/Client log will help you identify the cause:
090620 - Crash when picking Badge of Courage.zip (2.83 KB)

#52 - Flagged mines are still shown as neutral (gray) in the mini-map:

[size=75]Note: After playing around for a couple of hours, I can say the most annoying bugs seem to be #25 (game crash when hero is close to map edge in high res.) and #27/#47 (gained skill bugs which generate crashes later on if we try to open hero screen). So if you are planning a development version soon, it would be great if these bugs would be fixed among the first. :)[/size]


the error occurs in last build and it’s simple fixup to change one variable name in a code…
could you fix this? PLEASE

#53 - We still have redundant quotation marks in artifact description (a fix is mentioned in the changelog, but either it refers to sth else, or it didn’t make it to the 0.72 package):

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-RedundantQuotationMarks.jpg (VCMI)

#54 [size=75](similar to #46 and hardly a bug)[/size] - As seen in the screenshot above, the artifact name is displayed on 4 rows, because the number of maximum characters per row is smaller as compared to H3:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-H3HelmoftheAlabasterUnicornc.jpg (H3C)


I found a better example of the result of limiting the number of characters in the artifact name:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090710-GarnitureOfInterference.jpg (VCMI)

Should be fixed now.

ok hero bug fixed…

but new anim for tavern is probably displayed as in wrong format (let be bug #55)
(not whole animation box used, animation is very gray, animation looks like semi-random dots)

EDIT: I have forgotten about another bug
there it is
#56 hero can begin exchange with himself sometimes (if not always) when clicking space

What screen depth do you have set? It works fine for me.

Some issues with the Load a Saved Game screen:

#57 The screen opens in VCMI with the games apparently sorted: first by Number of Players and second by Map Version. In H3, the screen opens with games sorted: first by Map Version and second by Scenario Name.

#58 Sorting by Scenario Name does not work at all.

#59 Sorting by other categories works, but only ascending. A second click on the column header should sort in descending order.

#60 The map save date & time text is more detailed than H3 - which is okay - but perhaps because of the fonts used, it seems a bit too long in terms of occupied space:

http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090628-VCMIMapSaveTime.jpg vs http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090628-H3MapSaveTime.jpg

The real “bug” here however is the square character at the end of the VCMI Save time. It is redundant, unless you are planning to give it a certain functionality in the future. And I’m thinking here of some sort of button in this interface what would order the maps by date/time (the only option I felt was missing in H3). :wink:

#61 If a resource pile is at “0” and we have an event attempting to reduce that pile, not only should the pile not go under “0” (bug fixed in one of the previous versions), but also the event message window should not display that resource anymore.

e.g.: Start of “Adventures of Jared Haret” map on Impossible level, H3 vs VCMI:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090628-H3JaredHaretOnImpossibleStar.jpg vs i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090628-VCMIJaredHaretOnImpossibleSt.jpg

32bit desktop and 24bit vcmi (the default)
moreover intros work very well

Found one more issue in the Load a Saved Game screen:

#62 The Load interface opens with none of the Saved Games preselected, but actually with the game that would be first in the list in the New Game screen. We can even press on Load and the new game starts.

#63 Lean To says it’s “long abandoned” at first visit already.

#64 I lost the First Aid Tent in a battle, but hero still had it afterwards. Well, I think it still had it - I only noticed it the day after when I went back to my town to buy a new one, and I got a message that I already have one.

So far I haven’t managed to convince :stuck_out_tongue: any enemy to shoot in my War Machines again, to see if it’s reproducible. As I’m not 100% sure the tent disappeared after the battle, if you guys cannot reproduce it, try also buying a new one after you lose it in battle.

#65 Crash when trying to buy First Aid Tent after attempts to move all creatures into Garrison (very hard to reproduce):


Based on the error msg in the console - “Cannot take the last stack” - I figured the crash may have something to do with the fact that before trying to buy the Tent, I tried in different ways (creature overlap, splits) to move all creatures in the garrison (thus trying to leave the hero with no creatures, which shouldn’t happen). 5-6 attempts to reproduce it failed, until I remember also checking the Mage Guild first time when the crash happened.

Here is what I did the 2nd (and only) time I managed to reproduce it:

  • Load Autosave_2 game (attached below)
  • Go to Tavern and recruit Aeris
  • Move Elves & Dwarves in Garrison
  • Replace Dwarves with Centaurs
  • Open Mage Guild
  • Try to buy Tent
    (which is very close to the steps I took first time when I had the crash)

To my frustration however, I didn’t manage to reproduce it a 3rd time after trying the above steps, so I still don’t know exactly where the bug is. I hope you guys will find the answer in the attached logs.

Not sure if related in any way, but I remember that when I loaded Autosave_2 before the successful attempt of reproducing the crash, the game was 3rd in the list of Saved Games. However after that, next 5 times I went in to load the game, it was always in “its place” among the other Autosaves as below:

090706 - Crash when buying Tent.zip (107 KB)

Removing war machines after they are destroyed is not implemented yet.

Is it possible that you r-clicked on hero in tavern window before recruiting Aeris? Then it would be known bug with crashes after r-click on hero portrait.