0.72 bugs and issues

#41 interface issue
when message in ingame console is too long it overlaps the infobox, and when the message disappears infobox is not refreshed
I suggest line breaking for ingame console to getrid of this

I know that animation is not ideal at the moment but:
#42 changing animation speed through battle settings menu cause crash

#43 blue glowing border around selected creatures restarts every time when cursor moves (should be only on selecting creature)

Probably bug, maybe not - on Arrogance3 - battle with enemy hero on the coast begining on different battle arenas (attacking from top - battle on “dirt”; from right - battle on “boat”). In HoMM battle arena depends on position of defending army.

Bingo! SDL_mixer loads smpeg.dll - if it’s not not present in VCMI directory nor in windows/system32 music won’t play. Because it’s loaded dynamically I missed that dependency. It should have been included in the package.


I don’t know if it should be considered as a bug in VCMI or in the map editor.
I’ll leave it now as it is, though it may be changed later (possibly when support for sieges and town capturing is added).


#44 When killing all the creatures with a lightning bolt, a victory screen doesnt show, you have to play another move.
[size=75][Reported as 0.71b#48 - “Killing last enemy by magic doesn’t end battle”][/size]

#45 When an item is guarded by a creature, you get past them without having to fight, unlike H3.
[size=75][Reported as 0.7#48 - “Monster zone of control” - feature not yet implemented][/size]

#46 Lightning bolt kills the entire stack, regardless of their number. I just killed 41 goblins with Andra on level 1.
[size=75][Same as [b]#36[/size] reported above: destructive spells are overpowered]

[size=75]@fLuXx: Sorry, but I had to strike through the log numbers in your post above, as they were all previously reported, just maybe not in this thread. I hope you don’t mind. If you want to check the list of all bugs already reported, CLICK HERE.[/size]

#44 I see bug #47 from 0.71 reported problems caused by F4 when running both VCMI and H3. In 0.72 however, it seems F4 causes problems even without H3 -> for me VCMI crashes every time I try to perform (any) action in full screen mode, even when no other application is open (except the web browser, and of course other background applications like the firewall and what not, which however should not be the cause of it). And it doesn’t seem to be the resolution. I tried it on 800x600 and the same: as soon as I tried to move the hero at map start, it crashed.

I’m sorry, I had no idea. I’ve been following bug threads, but obviously not well enough. Next time I’ll see if a bug is already reported.

All sounds are OK but I have no music in game at all. Is this a bug? Directory “Mp3” with all files is present of course.

All what I found in the console on game start is:
Unable to play sound file 40(music parameter was NULL)

Have you added smpeg.dll to your heroes3 folder? Music started working as soon as I added it.

Thanks. Now it works, but:

**#45 **Music does not change when switching between towns.

#46 - When gaining the skill from a Scholar (and probably same from Witch Hut), “Intelligence” word does not fit on one row:


It’s possible that’s the longest word in a skill name, but just in case, maybe there should be a check for message windows to prevent that words are split in a funny way (ideally being that they are never split).

EDIT: - Redundant quotation marks from skill description are still there:
[size=75](reported by dikamilo[/size] as issue #45 in the 0.71b bug thread - Logged now in SourceForge)


#47 - bug with hero advancing
if hero gets twice the same ability at basic level (which shouldn’t happen but happens)
the hero window would make crash (in debug version it says it exceeded vector boundary, probably you just know what happened)

EDIT: it happens when hero gets a few levels at once
EDIT2: it hapens with advanced and expert too

INFO: it was tested with last build so may not apear in base vcmi 0.72

[size=75]Bug also in base vcmi 0.72 (I got Advanced Leadership like 5 times while advancing after a battle + crash) so I gave it a log number. Possibly related to #27 tho.


For instance this bug happens when the hero is leveled up several times after a battle. The server send several messages saying that the hero level up and to choose/upgrade a new ability without checking the previous choice. However each choice depend on the previous one.

#48 - Target creature loses stack size box from the moment the enemy shoots at it, or even starts to walk/fly towards it:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Targetcreaturesloosesstacknu.jpg [size=75](Arch Devils losing stack number box while Archangels were flying towards them)[/size]

In H3 only the stack number boxes of the attacking/moving creatures temporary disappear during the attack/move. Target creatures stack number box should remain displayed until the moment of the impact, when it disappears just for a fraction of the second in order to be updated accordingly (depending on casualties suffered).

#49 - Large stack numbers don’t fit very well in the boxes:
VCMI: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-StacknumbersVCMI.jpg vs H3: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-StacknumbersH3.jpg

#50 - Background creatures disappear from the Battle Casualties window if we move the mouse cursor out of the client interface:
Cursor still inside client interface: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Backgroundcreaturesbeforemou.jpg // Cursor moved outside client area: i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090619-Backgroundcreaturesdisappear.jpg

We can either scale number box or reduce info amount to “9K” as in H5. In second case, while using higher resolution the exact size of stack could be displayed below main window.

Of course, proper fonts will help as well :wink:

That’s indeed an alternative, though H3 had quite an elegant looking box, even if the number was 1 or 10000 (I’d start using the “k” maybe as of 100.000 or even as of 1.000.000 only):

#51 - Crash in the beginning of the “Chasing a Dream” map, when picking the Badge of Courage artifact next to the town:


I could not reproduce it:

  • Same map but other random artifact next to the town, worked fine
  • Custom map with Badge of Courage from editor, worked fine as well

So I hope the attached Server/Client log will help you identify the cause:
090620 - Crash when picking Badge of Courage.zip (2.83 KB)

#52 - Flagged mines are still shown as neutral (gray) in the mini-map:

[size=75]Note: After playing around for a couple of hours, I can say the most annoying bugs seem to be #25 (game crash when hero is close to map edge in high res.) and #27/#47 (gained skill bugs which generate crashes later on if we try to open hero screen). So if you are planning a development version soon, it would be great if these bugs would be fixed among the first. :)[/size]


the error occurs in last build and it’s simple fixup to change one variable name in a code…
could you fix this? PLEASE

#53 - We still have redundant quotation marks in artifact description (a fix is mentioned in the changelog, but either it refers to sth else, or it didn’t make it to the 0.72 package):

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-RedundantQuotationMarks.jpg (VCMI)

#54 [size=75](similar to #46 and hardly a bug)[/size] - As seen in the screenshot above, the artifact name is displayed on 4 rows, because the number of maximum characters per row is smaller as compared to H3:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-H3HelmoftheAlabasterUnicornc.jpg (H3C)


I found a better example of the result of limiting the number of characters in the artifact name:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090710-GarnitureOfInterference.jpg (VCMI)

Should be fixed now.