VCMI for Android


I leave it here…


How??? Teach us!

Little problem on Android

Im found a file format that does not crash. But still need to test. Im understand how make a mod and Ill do it. But i need more time.


I do not understand anything. I have crash in the tavern again with any type of video (even that used to work). But instead of the 3DO logo, any file is played, though slowly and without sound. I think this is a lack of phone resources and it is necessary to optimize the stream of video in the source code.


Is there anyway to use cheats on the latest build? On the play store version there was a ‘tab’ button that I could press and then the keyboard would pop up but I see no such option on the latest builds.

Any help would be appreciated.


I guess there is no way, new android version is not based on old one, and is delivered “as is” for now. VCMI team is working hard on actual gameplay features.


The only way for cheats on android now is to connect it to a keyboard


So from wha I understand only the SDL versions of VCMI had that cheat support…

Do you know what the latest version of VCMI android was based on SDL? I DON’T think it was 0.97 (The playstore version) and where I could find it?

Also unrelated but where did the google play version go? Was it taken down? It’s not there anymore:


There are now only dailies for android. For now at least. Can be downloaded here:



I wanted to try and get this working on my Fire 7 HD tablet (KFFOWI). So I downloaded the latest daily build and transferred over my GoG data to my sdcard to the vcmi-data folder.

When I first ran the app and tried i tried every codepage and every resolution and none actually launched. just black screen then wait a second then back to the launcher.

I then installed the extra resolutions mod which didnt fix the problem on its own but I noticed when I loaded up my logs they stated my devices native resolution was 1024x552

so then I edited the extraResolutions\Content\config\resolutions.json and .jsona files so the first lines “y” value was “552” instead of “600” so it reads like

“resolution”: { “x”: 800, “y”: 552 },

saving that will actually run the game and I know this is a stupid hacky solution but the game was actually up and running on my screen. I am able to mouse through menus and things but randomly when inputting names for hotseat will crash the game. and most frustratingly I cant even start a game at all once i click on begin game the game loads and sometimes ill see “red turn” for a second but most the time its just a straight crash.

I know there’s not much hope and my logs are no help. they don’t seem to point to a single issue at all and infact seem to stop randomly on a different line every time.

im mostly just kinda of pissed at amazon for screwing me out of 48 pixels? all specifications say my device is 1024x600 but its really not

EDIT: in a last ditch effort I grabbed a resolution changer app from the app store and gave myself an extra 48 pixels…10/10 would do again seriously fixed everything!..EXCEPT the input and it still crashes randomly but I can get ingame…

EDIT EDIT: so yeah fresh install with new resolution and random crashing everywhere. I can get in game if I’m lucky but it will crash after a moment. My device having issues is a KFFOWI amazon fire 7 tablet. not the nicest thing but has some power.


Hey, sorry to bother. i looked at the android daily builds and there hasnt been a new build in over a month? Whats happening?


Builds are broken because they are not fully integrated with project’s CMake configuration and from time to time adjustments are needed. Likely easy to fix, but since no one there to look after them they might stay broken for some time still.

Eventually I want to setup build system for Android properly and integrate it with main CMake, but it’s likely to take weeks of work to dig into it so no idea when this will be done.


I see. Thank you. Good luck!


I’ve downloaded the latest build (26-May-2018), but the game crashes when entering the tavern or finishing a battle. I’m using an honor 7 with android 6. Any suggestions maybe?


I can confirm that the latest daily build (from May) crashes while entering the tavern and finishing a battle. What are our prospects for fully-functional Android build?


Try to remove .vid files from original game data. As for daily builds they are broken again and nobody wants to fix them. Android is not a primary platform for development and there is no dedicated team to support it.


I wonder if you could add support for Samsung Note 9 S Pen button to be used as right click. SCUMMVM supports it. Also it looks like Galaxy Tab tablets have S Pen with button too.



Hi Everybody,

Just joined the VCMI experience, it seems awesome :slight_smile:
I am on Xiaomi redmi note 5 with Android 8.1, I am trying to run Homm3 but it crash straight after launching VCMI no image of the game starting. Did copied “Maps”, “Data” and “MP3” folders in the folder like the wiki said. Any ideas what would be the problem ?

Many thanks


xyz vcmi is not supported now. Better download android version from here:


Thanks misiokles, will try that.