VCMI 0.73 - Bug reports

#35

Yep,I think there is problem with hungapp. My game also freezes many times but crashhandler not appears and there is no dmp file. Always these kind of crashes are not reproducible. Added logs of last freez.
Freez at the begning of game when I tried to collect the ore.
img134.imageshack.us/img134/6274/crashunknown.th.jpg
And the consequence of task manager activity.
img134.imageshack.us/img134/6610/crashhungapp.th.jpg


refer to crash #45 added one more set of log files, maybe it will help to find the crash reason
img268.imageshack.us/img268/2057/crashmeetingscreen2.th.jpg
EDIT: I’ve noticed that it can be problem to display creatures. In previous post #45 there was no creatures displayed in status window, here are no creatures in heroes’ army.
crash_meetingscreen 2.zip (193 KB)
crash_unknown.zip (3.32 KB)

#36

You may try to enter “crash” command into he console to force the crash and dump report generation. In case of freezup, please also check (with Task Manager) CPU usage by VCMI processes.

Thank you very much for detailed info. I’ll make some changes that might fix the issue. It’ll have to be retested with the next build.

#37

This time game stop working while I do something else, it also happens from time to time.
I’ve tried to enter “crash”. It didn’t work, but it dumped the memory usage from 220M to 8M.
CPU usage didn’t change. On my PC (Pentium 4 CPU 2,5GHz, 2,5GB RAM) it is: Adv.Map Screen <10,30>, Town Screen <20,30>, battle <30,40>. Memory usage start from 120M and what is interesting every round (autosave) takes about 5M more (medium map), so after 20 saves it became 220M.
EDIT:But if you switch to full screen (F4) then memory usage lower to about 18M (from ie 250M).
img194.imageshack.us/img194/7229/freeztest.th.jpg
Another thing, when I had to close the application in task manager there were two (not one) VCMI (clients) not responding. Added logfiles after ended task.

I’ll try to keep control it during next games also on other computers.

EDIT: I’ve just left the game loaded for longer time doing something else. The game freezed one more time. Typing “crash” didn’t work, too.
img5.imageshack.us/img5/3585/crashfreeze.th.jpg


#58 crash after appearing strange colors at meeting screen (maybe it is also somehow connected with crash #45.

img156.imageshack.us/img156/593/crashstrangemeetingscre.th.jpg img200.imageshack.us/img200/593/crashstrangemeetingscre.th.jpg
crash_meeting screen 4.zip (203 KB)
crash_meeting screen 3.zip (225 KB)
crash_after strange meeting screen colors.zip (195 KB)
crash_freeze 2.zip (2.37 KB)
crash_freez.zip (23.2 KB)

#38

Ok, I’ve been playing beyond game limits and here’s what I got:

#59 Giving hero 99 999 999 exp from map editor prevents map from launching with no error message.
#60 Giving 99 999 999 exp from Pandora Box or Event does noting, even though all other functions work normally.
#61 On hero screen current exp is said to be always 0, even though he advanced levels normally.
#62 Crash when magic arrow with 502 spellpower hit enemy peasants
Testy1 exp.rar (2.87 KB)

#39

I learned that tree can’t give more exp than 2^16 (old integer?), now trying to change variable types to 64 bit.

#40

#63 No message about preventing spell casting during battle if you use “Orb of Inhibition”

#64 No info in status window if you collect guarded resources.

#41

Handled, which leads to another bug:

#65 When gaining multiple levels at once, hero can be offered same secondary skills many times.

#42

Duplicate to 0.72 #47 bug.

#43

Ok guys, after updating the last build game crashes immediately after launching any map, with no error log.
The last and only package applied is Set Selection.

#44

#66 - After selecting a spell during combat, l-click should be locked for any action other than casting.

Right now we can still access the combat menu buttons: Options/Surrender/Retreat/Auto/Scroll/Cast/Wait/Defend. None of these should be accessible while a spell is selected. And also r-clicking on any of them should not display the info box, but cancel the spell (same as r-click anywhere else); and only after cancelling the spell r-click should open the info boxes.

#67 - Spell immunities don’t seem to work (I would have thought the feature was not implemented yet, but then I saw some were reported once as fixed?):

Ice Elementals don’t have Ice immunity
Fire Elemental/Firebird/Phoenix don’t have Fire immunity
Magma/Energy/Psychic Elementals don’t have Mind spell immunity
Magic Elementals don’t have any Spell immunity
etc.

#68 - Incorrect display of the mouse cursor during enemy’s turn in battle (frozen shaded hex i/o mobile arrow)

VCMI: http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090818-CursoronenemysturninVCMI.jpg - Cursor disappears, leaving a frozen shaded hex (until enemy ends their movement)
H3: http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090818-H3Cursoronenemysturn.jpg - Cursors changes to an arrow, which can still move during enemy’s turn; and there’s no shaded hex on the battlefield during enemy’s turn

#45

I’ve implemented it yesterday (not tested because it seems to be quite hard but the code is quite simple).

#46

#69 - Placing artifacts back in backpack (or swapping), if you have more than 5 artifacts there, does not put the artifact in one of the 5 visible slots where you clicked. You’ll need to scroll for it to see where it went. You can reproduce it with Ivor in the attached map.

In case you just place an artifact in the backpack, you only need to scroll once to the left to find it. However if you take an artifact from the backpack and swap it with one on the hero, you’ll really need to scroll through that backpack to see where the other artifact went (I didn’t figure yet the logic used to place a swapped artifact).

[size=84]But this bug gives me an idea: maybe it’ll be nice if VCMI would add a small button or hotkey to sort all backpack artifacts, first by destination slot, then by value. I’ll log this in the “Missing features” thread. ;)[/size]
VCMI Tests.h3m (9.24 KB)

#47

#70 Creatures’ dwellings do not require FORT to be built if there is already built first lvl dwelling (except CASTLE town).

#71 Bug with sailing - boat can sail through the edge of the land, noticed before, but I thought it didn’t affect the game. Now it seems to be bug.
The map is “Search for the Grail”. Attached with added hero in the place screenshots are made. First pic is from VCMI second from HoMM.

img149.imageshack.us/img149/5529/bugsailingthroughedgeof.th.jpg img149.imageshack.us/img149/1176/bugsailingorg.th.jpg
Search for the Grail_edit.h3m (20.5 KB)

#48

#72 The calculations for finding possible hexes to move to in battle do not seem to take into account the nature of 2-hex creatures. In the picture below, the Silver Pegasi should not be able to move in front of the Arch Devils.

EDIT: Maybe this is the same as #08? In any case, it should hold for all 2-hex creatures.


#49

And if you do try to move them there, what happens? Crash?

#50

No, the server will send a message that the unit cannot be moved there. I could attach a map but the problem is easily reproducible, just create an army like in the picture and attack a group of Arch Devils and they will start out by going for the Grand Elves just like in the picture every time.

#51

I think it’s not a problem with not recognizing that creature is two hex wide but a problem with not blocking side colums of hexes when it should be done. I think it’s not hard to fix.

#52

You’re right, it was really just a special case with edges of the battlefield. I should’ve fixed it now.

#53

Refer to crash #45, it’s happened one more time (attached new dump and log files)

BTW: I’m not sure if I should continue to add the log files for this bug? Do you know what is the reason?

img136.imageshack.us/img136/3157/crashmeetingscreen5.th.jpg


#73 Crash at the start of the battle - I’m nearly sure that I (or somebody) has reported this crash but I couldn’t find it. I don’t know if it shouldn’t be fixed. If it is new, please assign the next number.

img21.imageshack.us/img21/3006/crashbattlestart.th.jpg img21.imageshack.us/img21/6071/crashbattlestartcd.th.jpg
crash_battle start.zip (123 KB)
crash_meeting screen 5.zip (161 KB)

#54

I gave it a log number because with crashes you never know: even if it looks similar, it might have a different cause. Plus the fact that the previous reports were not kept in the logs, could mean that the devs made already some changes which should have prevented it to reoccur.

Anyway, just in case it’s related and previous descriptions are helping, here are the other reports:

0.72#71: [forum.vcmi.eu/t/0-72-bugs-and-issues/170/60)

0.72d#2: [forum.vcmi.eu/t/vcmi-0-72d-development-version/190/4)