VCMI 0.72c - development version

I’m releasing a new version, because previous build had severe bug that practically made impossible to continue loaded game.

There are practically no new features, just bugfixes for issues reported in 0.72b thread (and one 0.72 issue).

Unresolved bugs from 0.72 & 0.72b builds:
(state for Jul 26)

vcmi_072c.7z (1.79 MB)

#1 We seem to have a small issue with some WoG descriptions, which are probably hardcoded, that do not fully correspond to the H3 functionality: (In H3 there is no mention of mind spell immunity for Badge of Courage)

EDIT: Thanks to Fnord’s clarification below, it seems the H3 description was incomplete in regards to the artifact’s attributes. But the WoG description should be amended as well, by removing “hostile”, as the artifact makes all friendly creatures immune to all mind spells, including beneficial (i.e.: also Mirth & Frenzy).

#2 Heroes order at map start is different than H3. Load the attached map in H3 & VCMI. In H3 the order is always clear: first all RoE (original) heroes, sorted by alignment, class and then their order from MainMenu/MapEdit, followed by expansion heroes, again sorted by alignment and class. When loading the attached map in H3, you’ll see that you have first the Knights (but w/o Sir Mullich), then the Clerics, then Astral the Wizard, and at the end Sir Mullich, who is an expansion hero. In VCMI however, the order does not seem to make much sense. I did notice however that it has something to do with the changes I make in MapEdit (the last hero I edit changes his place in the list next time I load the map).

Regarding 0.72#49, personally I wouldn’t limit it more. H3 could fit up to 6, so I wouldn’t go as low as 4. Maybe we can try a smaller font in the next dev release, and see if it looks fine.

Regarding 0.72#69 - I see the bug preventing the animation is fixed, however there are still a few issues related to it:

#3 Luck animation is too short and probably also too low. I barely noticed it, even with slow animation speed. And from what I’ve noticed, it seemed to be positioned a few millimeters too low on the creature (though I need a slower/longer animation to tell exactly). Mirth animation also seems too short.

#4 Animation sound for Fortune is not working yet. Again - same for Mirth
[size=75](This might be ‘not implemented feature’, but as long as the item is marked as implemented in the vcmi-status file, I prefer to report here whatever is still missing related to it)[/size]

#5 The occurrence of luck in battle seems too low. I might be mistaken though… Still, it could be that the formula is not entirely the same, the skill level or the equipped artifacts are not all taken into consideration correctly. In the attached map, we have Sir Mullich with Expert Luck + 3 Luck Artifacts, with a 7 stacks army. In H3, I get at least 1 Luck per turn, sometimes 2, or even 3 (with retaliations). In VCMI however, I seem to get maximum 1 Luck per turn. It even happened that I had only 1 Luck in 3 full turns (with Sir Mullich’s 7 stacks army).
Test Map.h3m (4.73 KB)

I think we should leave it until we have support for original font. Smaller version of our fonts are much less readable.

#06 Kind of double click if you choose hero from the heroes list in the resolution 800x600
If you click (LPM) on the fourth or upper side of icon of the fifth hero automatically causes to get into spell book. So if you click on place exactly where on the next window will be the spell book icon.
Cause of my english I’m not sure if you understand what I mean (see the screenshots)

#07 Some layer problems. Similar bug Zamolxis described as bug #22 in vcmi 0.72b with “leave guards” window

#08 Game crashes. Just get into town (do not have to build anything), leave the town, move cursor, after few seconds game crashes (repeatable). No idea what is the reason. (see attached save with 2 versions of logfiles)
There is even no need to get into town. Just click on the town, map will centre, then move cursor near the witch hut(with first aid skill). If you don’t click on the town nothing happens. (163 KB)

#07 must have slipped in while trying to fix 0.72b#22. :slight_smile:

Both #06 & #08 are easily reproducible:

#06 is because on the 800x600 resolution, the Hero screen opens positioned as such, that the spell book box is in the area above all left side of the 4th and only upper left side of the 5th hero icon in the list. And the bug is that the click used for opening the hero screen, somehow acts also as a click in the same spot of the new screen.

#08 happens whenever we select a town, and then we hover over a visited Witch Hut.

Boulie’s #06 reminds me of another small bug:

#09 Mouse click during the intro video (to skip it) acts also as a click in the first Main Menu screen to come. For example, if our mouse cursor is somewhere in the upper right hand side of the Client window when we click to skip the intro video, we end up directly into the New Game menu. I guess if you get used to it, it might turn out to be a “bug/feature” saving us from an extra mouse click, provided we click to skip video in the right area of the screen. I leave it up to you to decide if this needs to be fixed or not. :slight_smile:

[size=75]And a few others:[/size]

#10 Ellipsis is handled as 3 separate characters by VCMI, while it should be considered one single character. Or else a workaround needs to be found to avoid narration layouts like this:

#11 Hmm… I’m not even sure if I should report this one, as I’m beginning to like it more as it is in VCMI. But here it goes (and I let you decide if you want to change it or not): In H3, when we could not build a structure (i.e.: Shipyard when no water, or structures disabled from MapEditor), the icon label was grayed out - already implemented correctly - but also had a red x in the lower right hand side of the icon (as for the buildings that can’t be built due to lack of resource or pre-requisites). For some reason though, not having the red cross makes the icon look a bit more slick in VCMI (but maybe it’s just me). It also diferentiates it even more from the other icons where the red x (together with the red label, granted) indicate some requirements are not yet met. It may also look nicer in a fully built town to not have red x’s anymore, I don’t know. I feel the grayed label and the description if we r-click are enough, so I leave you guys (and/or other testers) to decide if you want to add the red cross as well or not…

#12 Shipyard built in Map Editor is not “un-built” when we start the game, if no water around the castle. In H3, even if we were forcing a Shipyard from the Map Editor, that was removed at game start (not in Town screen + grayed out icon if we would have wanted to build one). Important note: Removing of the Shipyard if no water around, should not also remove the Lighthouse, in case that was added as well in the Map Editor. The Lighthouse graphic in town screen and its functionality should be there, only no mention of it in the town hall build interface (which should still display the Shipyard as grayed out).

[size=75]FYI - Yesterday I went through all the bug threads from before 0.7, checked all the posts, and I can confirm that all items reported until 0.69 are either fixed/implemented or already logged again in one of the 0.7x threads (or in the Missing features sticky). As of today I started checking all reports starting with the 0.7 release, to see if all bugs until 0.72c are either fixed or logged in SourceForge (or else I’ll log them in there). Partially solved old issues will be logged here as new bugs, same as #13 below:[/size]

#13 The scroll arrows in the Recruit window should be grayed out if no creatures or not enough resources available.

[size=75]This is the last remaining bit to completely implement all items in the Recruit window correctly, as reported in the 0.7 thread (particularly 0.7#12.2).[/size]

#14 Identical with the above, the scroll arrows should also be disabled/grayed out in the Marketplace window, when the from/to resources are not selected yet.

[size=75]Following the same logic as in the Recruit screen, I would expect the buttons to be grayed out also when we cannot trade at least 1 resource of the selected ones. However that is not the case in H3. I would prefer it grayed out in this case, to make it obvious that clicking on those scroll arrows is pointless anyway; but I leave it up to you if you want to implement it as such, or like in H3. :)[/size]

#15 Similar to the above two, the Split Stack button (Town screen, Hero Screen, Meeting screen) should be disabled/grayed out when no creature is selected.

[size=75]In the Town Screen, if SUGGESTION #5 is implemented, the Split Stack should be disabled/grayed out only when neither creatures nor heroes are selected (unless you foresee a different button for in-town meetings). If Suggestion #5 is left out, then the Split Stack button should be grayed out even when heroes are selected.[/size]

#16 Diplomacy doesn’t seem to be implemented correctly yet (not just the skill, but in general the principles of monsters joining heroes or not). In the attached saved game, Ivor has no Diplomacy skill, and both him and his army belong to a totally different alignment than the Wraiths in front of him. The Wraiths are also set up as Aggressive from the Map Editor, so they should definitely not want to join him. And just to make sure, I checked that in H3, with a map edited so that Ivor attacks them with the very same army, they do not join. However in VCMI, if you load the attached game, the Wraiths will join him.
090716 - (75.1 KB)

Mana points still can become below zero.

#17 - In unit recruiting window unupgraded creature is selected by default. Should be selected upgraded one.

#18 - After recruiting hero, on adventure map new hero is overlapped by town(screenshot).

#19 - Strange sound problem: attack dwarves near mercenary camp by Loynis - about 50% of your actions cause sound “dwarf hurted” to play (Save attached)

BTW - I think that #12 should be similar to multiple capitols in the editor (not H3 behavior) - if mapmaker decided to build harbor in city, it should remain there (but ther is no way to build a ship there).

Games.7z (53.2 KB)

#20 Main Menu - New Game - Advanced Options: For the Human Player selected to play with (and if there is no hero already given by Map Editor) the arrows for selecting Starting Hero should not be displayed as long as a specific town is not selected. For the Human Players controlled by AI, the arrows for Starting Hero should never appear, even if we select their town.

[size=75]This remained pending since 0.7#21 was partly fixed. If you have the time, it would be nice if you could also add the subtitles to the Advanced Option interface. :)[/size]

#21 Small graphic glitch above file date, after moving up and down selecting different games in the Load Menu:

#22 Grand Elves attack twice also in melee (like Crusaders:). They should only shoot twice, not also stab twice. :slight_smile:

#23 All heroes start with 0 Experience now. I believe in H3 they were starting with a random value between 10 (or 20?) and 100.

Note: [size=92]H3 had a small “bug” here, namely that if you were setting any value for Experience in the Map Editor (even “1”), the game was loading it correctly, but if you were setting “0” as customized value, the game was ignoring it and giving the random starting experience. So when fixing this, it would be great if you could make it as such that “0” is also recognized as pre-set starting experience. Only when nothing is set from Map Editor, the game should auto-generate the random value.[/size]

#24 Esc key does not close the Marketplace window (and it should even trigger the “Press Check button” animation, same as when we press Enter).

#25 The graphics of the Surface View button still need to be adjusted for the 1024x768 interface:

#26 This is minor, but still: Resource values in the Trade area of the Marketplace window (“Qty to trade”) are not perfectly centered. They are about 1mm to the right, as compared to H3 (if you Alt+Tab between a H3 and VCMI Marketplace, with resources selected, you’ll see the difference)

#27 - Fairly minor, however a part of H3 functionality. When a hero picks up a resource pile, hero information does not return automatically after a little while (until you change to another hero or town then back to the original hero).

#28 - Sound does not play when picking up an artifact. Also no terrain music yet.

(I like all the music that has been introduced so far though, thanks to all that have contributed! :slight_smile:)

Best regards,

#29 Custom creature animation in battle does not work for the active stack (the one with the glowing yellow border around).

[size=92]When we hover over a stack, a custom animation is triggered. In H3 that included also the active stack, while in VCMI it’s only valid for the passive ones.[/size]

#30 Spacebar does not move the hero between the 2 entries of the Subterranean Gate. [size=75]Also, H3 had a fading effect between the Surface & Underground, which is not yet implemented in VCMI.[/size]

EDIT: Thanks to Boulie’s post below, I did some more tests, and it’s not Spacebar that is causing the problem. It’s actually my heroes going to the Underground and not able to come back up. Please see the attached map as it’s always reproducible.
Test Map.h3m (4.8 KB)

#31 H/next hero button – should switch between heroes with path left not without

#32 if load saved game with garrisoned hero in castle and you enter any of other hero to the castle there always show the meeting screen with the hero even if this hero is already out of the castle (added saved game)

#33 if you change the resolution in console (not setting file) during game play the screen somehow changes: the battle screen, the frames of main window, and there are problems and crashes if you swith between full screen and window mode. I think it should change after new game restart/load and the new resolution should be default and saved in the setting file

I think it is ok. Spacebar switches between underground and surface. (70.8 KB)

Hi Zamolxis. Actually, the Badge of Courage description does correspond to the H3 functionality. Whether or not it was intentional on the part of the original H3 coders (it seems to be a fairly powerful ability for that class/value of artifact), mind spell immunity has always been an undocumented feature of the Badge of Courage, which is why we eventually added it to the WoG description (so everyone would know).

In any event, I think the descriptions for artifacts are all stored in editable text resource files.

However, the WoG description says hostile mind spells. I believe it’s all mind spells that are blocked, including Mirth and Frenzy (the two beneficial mind spells), unless it was changed to hostile-only in WoG (unlikely but never know).

  • Fnord

Hi Fnord. It’s good to see you. :slight_smile:

Thanks for the information. I didn’t know that. Actually, while reading your post, it started to ring a bell… I may have probably read that long ago on some WoG forum, but forgotten about it since.

Well, I guess that makes #1 a non-issue. :wink:

Thanks. :slight_smile: Yes, except that the word hostile should probably be removed. :slight_smile: - Fnord

34 Game crashes if hero is in the “school of magic” and another hero comes to transfer creatures to him.After closing meeting screen apears screen from school of magic and game crashes with comment: “R6025 - pure virtual function call” (see attached save). The problem is caused probably because for meeting screen one hero is on the other but should stand next to him. Similar situation is with attacking hero/creature. (132 KB)

Correct… I’ve double checked in H3C just to be 100% sure I don’t give misleading reports (again:p), and “hostile” should be removed from the artifact description. I’m gonna update my original report.

#35 Heroes in town do not always learn the spells at Mage Guild (even though they have the Skill and the Spell Book).


  • If we build Mage Guild level while hero is in town
  • If hero enters town at the end of its movement
  • If hero enters town with Spacebar


  • At game start (if Mage Guild is built & hero has spell book, unless we use Spacebar or movement to enter town).
  • If the hero gains a higher Wisdom skill while at town gate (i.e.: siege), while in town there is a high level Mage Guild built (again, unless we enter town with Spacebar, or later on at movement end)

To easily reproduce it, simply load the attached map and do the following:

  1. Open Neela’s hero screen and check the spell book: only 1 starting spell
  2. Enter town with double click on town or town icon. Open Mage Guild to see available spells.
  3. Double click on Neela’s portrait in town and check the spell book: she still hasn’t learned the spells
  4. Exit town screen and re-enter with Spacebar. Check Neela’s spell book: now she knows the L1/L2 spells
  5. Build Mage Guild L3.
  6. Exit town screen and visit the Scholar to get Basic Wisdom
  7. Enter town with double click on town or town icon.
  8. Check Neela’s spell book: she hasn’t learned the new L3 spells yet

Note: To fix this so that it works like in H3, you only need to make heroes learn new spells whenever they visit the town, regardless of the way you open the town interface.

Perhaps ideally would be to implement it as such that heroes can learn spells when at town gate, without the need of opening the town screen:

  • at map start or beginning of new turn after a siege, check the spells in Mage Guild
  • then check hero’s Wisdom skill to see if he could learn any new spell from the Mage Guild
  • and only after that the new turn autosave to take place, and hero is free to move on
    Though I can see how that would require pretty ugly code, plus potential risk of new bugs. Probably not worth the effort. :stuck_out_tongue:
    Spell Learning.h3m (8.56 KB)

#36 Killing a stack of our own during its turn with a spell, leaves a ghost image of the stack on the battlefield:

  • the stack does not have a number box anymore (see screenshot)
  • the creature can still move (as it was its turn before the spell), but just this once
  • afterwards other creatures can simply walk over it as if it wasn’t there anymore
  • if it’s the last stack of your own that you kill during the battle, after you move the ghost creature the game crashes

It’s easily reproducible if you load the “Spell Learning.h3m” map attached in the post above, then attack with Sir Mullich and use area spells on your own creatures during their turn. Otherwise please see the client log attached here below.

#37 Haste gives speed bonus to War Machines. When their turn comes, we have an area of shaded hexes around them, as if they could move. If we try to move them, the game crashes (easily reproducible - but I’ve attached the logs as well just in case)
090725 - Own stack killed by spell during its turn - (2.23 KB)
090725 - Crash when trying to move ballista in (2.59 KB)

#38 Wrong growth of creatures. See attached save, there is beginning of new week all creatures was bought out at the end of the week.

#39 Moving hero through the mountains. (the same save - hero Axsis)

#40 Wrong stack queue in the battle if there are creatures with the same speed first attack all creature the attacking hero then opponent, ie: if you attack creatures with speed 6, 5, 5 and 5 against creature speed 5, after creature with speed 6 should attack opponent and then rest of your creatures, but now is that attack all yours creatures and then opponent. (128 KB)

I think I managed to figure this one out. And it has nothing to do with the size of the target creature. :stuck_out_tongue:

Steps to reproduce:

  • Load the “Spell Learning” map attached to my post above (3 posts back)
  • Attack Galthran with Sir Mullich
  • Cast Haste in the beginning of the battle, then use Wait on all your creatures
  • Enemy will start moving all the Skeletons as if their only target is the Pikemen (and let’s give this issue log #41, because AI should try to go after the shooter or the flyer, unless the pikemen would be reachable in less number of turns)
  • Move the Archers as in below screenshot, so that they are 4 hexes away (Skeleton Speed) from the nearest Skeleton which was heading for the Pikemen
  • Then move the Pikemen & Griffins somewhere behind the Archers
  • Next turn start by making all your creatures Wait
  • When enemy’s turn comes, he will move the skeletons as in the below screenshot, including the one that went just in front of the Archers, without attacking them

Note that the Skeleton didn’t stop in front of the Archers w/o attacking to block their ranged ability. I’ve reproduced the same scenario switching Archers with Griffins or Pikemen - the Skeleton also stopped just in front of the Griffins/Pikemen w/o attacking. I’m not yet sure, but it seems they only can’t recognize the creature in the next hex at the end of their movement on the horizontal. That because I tried to reproduce it from other angles, and then they did attack me if I was placed on the diagonal. I hope this information helps you find the exact reason behind the bug. [size=75](See also the movement area of the Hasted Ballista reported as #37) :wink: [/size]

#42 Monolith bug - you can block the monoliths.
If hero is in monolith and you want to transfer creatures with other hero the meeting screen appears but you can not transfer anything because hero is already teleported to other location.
Second thing if one hero is in monolith and you want to enter monolith in different location you are unable to do it, there should appear the meeting screen

Attached save for this bug (157 KB)