Infinite connecting (win 10)

#1

Hello, I’ve downloaded the latest VCMI build, install the VCMI and later install the town mods too. Everything works like a charm except if I click single player, multiplayer, and load game, the connecting window never disappears. If I cancel and click again, the game’s crash. I did change the port number but it didn’t work either, does anyone have a solution for this? Thanks.

#2

Possible solutions.

  1. Your antyvirus software blocks somehow connection between vcmi_client and vcmi_server. Try to add them to white list or something.
  2. Some vcmi files (saves or logs) are located in: C:\users[your_pc_name]\Documents\My games\vcmi

If [your_pc_name] contains non-eglish letters - there infinite connecting. Solution is… create another window account with only correct english letters…

#3
  1. I’ve disabled the antivirus but it doesn’t work either
  2. I cannot post my logs because I’m still a new user. What’s the requirement in order to attach files?

My user name is just simple english 4 letters, but I found a weird behavior while troubleshooting VCMI. If I restart the computer and run VCMI again, the connecting window disappeared in a few seconds later and the usual scenario pops up. But if I exit and rerun again, the infinite connecting window occured again until I restart the computer and run VCMI again. TL;DR restart PC temporarily fixed the infinite connecting issue until I exit and run the VCMI again.

#4

I expect it might be because you exit game using red cross, Alt+F4 or something. You should exit it using menu buttons. In case if you closed it incorrectly you need to open task manager, find vcmi_server.exe process and kill it.

#5

Well, what do you know, it works after I stopped the vcmi_server.exe in task manager. Now I can exit and rerun VCMI without infinite connecting window! Thanks for the help!