Crashed in editor?


#1

wrong
Could anyone help me for this wrong issue?


#2

One of your mod has wrong syntax. In one of your json at line 75. VCMI map editor is more sensitible for format syntax than vcmi console. So, you must investigate by trial-and-error method which mod causes editor error and next which json etc.


#3

There are many mods…how can I find the error?


#4

My method is… copy all mods to temporary folder to get clean vcmi. Launch map editor. If editor start without errors - close it. Then copy one mod (or two, or three) to vcmi/Mods folder and lauch map editor again. If starts without errors, close it and copy another mods. Yeah, it is annoying and boring but in such way I fixed many mods to be compatible with map editor.


#5

Sure, it is boring but effective…I will try, thank you


#6

One of issue that map editor doesn’t like. If you using mods with some new war machines it is required to have map def of artifact part of new war machine. Game doesn’t require it (war machines cannot be found of the adventure map), but map editor is harsh of these things…


#7

when I start the map editor I have this message

2018-11-13_07-49-08


#8

Which mod cause this?


#10

how to make the map editor work with h3bitmap.lod,h3sprite.lod of heroes of might and magic gog version or hota version?

I keep having this message
https://forum.vcmi.eu/uploads/default/original/2X/d/d1937ed89615415784caf127e167b23527a88be1.png


#11

It complains about 6 level of magic guild, definitely a bug somewhere.


#12

I hope it is resolved


#13

This bug is located in your own mod - Forgotten Fields. You can’t just type “mageGuild” : 6 and expect that game understand 6th mage guild level :slight_smile: Check your cyan castle jsons.


#14

where did you see “mage guild”: 6 I can not find it, I checked the buildings.json file of cyan castle, eldorado and northerners but nothing seems to me all exact