Forum index VCMI Project - Heroes 3: WoG recreated
Forum of the project aiming to recreate best turn-based strategy ever!

FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  StatisticsStatistics
RegisterRegister  Log inLog in  AlbumAlbum  DownloadDownload

Previous topic :: Next topic
New login security measures
Author Message
Tow 
Project Lead
VCMI Programmer


Joined: 01 Feb 2008
Posts: 1407
Location: Kraków, Poland
Posted: 2011-01-24, 00:15   New login security measures

Last days we have received many complaints regarding bots trying to break into your accounts and causing forum security mechanism to temporarily (for 40 min) block the account. Attacks come from many different IPs.

To ensure that your accounts are safe and keep bots from triggering blocking mechanism, we introduce a CAPTCHA check for logging in. It's very simple, basically the same as used for registration and posting without registration. You just have to type "VCMI" to the new field in the login form. It should do the trick, until better solution is implemented.

I'm sorry for inconvenience but that's certainly better that being bombarded with mails about failed login attempts.

If you encounter any difficulties accessing your forum account, please write me (tow AT vcmi DOT eu).
_________________
VCMI is a work in progress.
VCMI is NOT an another mod.
 
     
q4a
Guest
Posted: 2011-02-25, 19:53   

Can't register. CAPTCHA don't show pictures.
Tested on chromium and firefox, so seems like a forum problem.
Can you check it?
 
     
Warmonger 
VCMI programmer


Age: 28
Joined: 07 Jun 2008
Posts: 1541
Location: Warsaw, Poland
Posted: 2011-02-25, 20:06   

There are no pictures. Read carefully.
_________________
Think twice if you really need to send me private message. Use public forum for general questions.
DJ Warmonger blog
beegee wrote:
Warmonger, you are the best!
 
 
     
q4a

Joined: 26 Feb 2011
Posts: 42
Location: Russia*
Posted: 2011-02-26, 08:10   

Sorry, my mistake.
 
     
Zamolxis 
Moderator


Joined: 24 Feb 2008
Posts: 744
Location: Brussels, BE
Posted: 2011-02-28, 14:20   

q4a wrote:
Tested on chromium and firefox...

Just curious, did you post the above with chromium or firefox? Because the forum shows it as safari, so we might need some further fine tuning of the browser recognition. :p
_________________
Tips for testers:
- Check the bugs already reported in the BUGTRACKER, to avoid creating dupes
- Check the ITEM IMPLEMENTATION STATUS lists, to avoid reporting as “bug” a feature not yet ready for testing
- If you feel the devs should prioritize a certain feature implementation, please add it to the Missing features & functionalities thread.
- Enjoy! :)


The use of the EDIT button is strongly encouraged on the forum. ;-)
 
     
Display posts from previous:   
Reply to topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Add this topic to your bookmarks
Printable version

Jump to:  

Powered by phpBB modified by Przemo © 2003 phpBB Group

Hosting provided by DigitalOcean
Page generated in 0.02 second. SQL queries: 12