Forum index VCMI Project - Heroes 3: WoG recreated
Forum of the project aiming to recreate best turn-based strategy ever!

FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups  StatisticsStatistics
RegisterRegister  Log inLog in  AlbumAlbum  DownloadDownload

Previous topic :: Next topic
Problem with starting the game [error in JsonNode.cpp]
Author Message
Adamus
Guest
Posted: 2012-10-30, 14:01   Problem with starting the game [error in JsonNode.cpp]  

Hello

Today I tried to compile and run VCMI. I followed this instruction http://wiki.vcmi.eu/index...lation_on_Linux. Compilation was sucessful, but when I tried to run it, I got following error. Does anyone know where the problem is?



Code:
[adamus@arch client]$ ./vcmiclient
Starting...
Creating console and logfile: 0
         Initialization: 10
         Data loading: 150
                Found mod filesystem: ALL/MODS/VCMI/FILESYSTEM
                Found mod filesystem: ALL/MODS/WOG/FILESYSTEM
         Mod filesystems: 10
File system handler: 170
Failed to open file
Last system error was : No such file or directory
Loading settings: 170
VCMI 0.9 (client)
Note: SDL suggests to use 32 bpp instead of24 bpp
New screen flags: 0
        Initializing screen: 80
        Initializing video: 0
        Initializing minors: 0
        Initializing sound: 20
Initializing screen and sound handling: 20
        Mod handler: 0
[smk @ 0x1f86ca0] max_analyze_duration 5000000 reached at 5066160
        General text handler: 10
        Hero handler: 20
vcmiclient: /home/adamus/dane/git/trunk/src/lib/JsonNode.cpp:223: const JsonMap& JsonNode::Struct() const: Assertion `type == DATA_STRUCT' failed.
Przerwane


I'm using Archlinux.
 
     
Ivan 
VCMI programmer

Age: 23
Joined: 08 May 2009
Posts: 1336
Location: Ukraine
Posted: 2012-11-01, 10:54     

Make sure that DATA_DIR/config (usually /usr/share/vcmi/config) is identical to SOURCE_DIR/config.
Copy it or make a symlink to be sure.

Have you installed vcmi from 0.9 source package or from current svn?
 
     
Adamus
Guest
Posted: 2012-11-01, 21:44     

I'm using SVN version. You was right. My DATA_DIR/config and SOURCE_DIR/config was different. Now everything works fine.
Thanks for help.
 
     
Display posts from previous:   
Reply to topic
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Add this topic to your bookmarks
Printable version

Jump to:  
Quick Reply
Username: 


Expire Days
 
 
 
 
 
 
 

Powered by phpBB modified by Przemo © 2003 phpBB Group
Template Chronicles modified by Nasedo modified by Tow.
© VCMI Team
Page generated in 0.05 second. SQL queries: 11